Blackbaud is requiring customers to upgrade to versions of their products that support TLS v.1.1 or higher by March 15, 2018. On that date, Blackbaud will begin disabling the TLS v.1.0 encryption protocol in our solutions, so Blackbaud can complete development and testing prior to the PCI Council’s June 30, 2018 deadline. After March 15, 2018, customers still using TLS v.1.0 will not be able to access some of their Blackbaud solutions.

Users will need to upgrade to an upcoming 7.96 patch by March 2018. The patch is planned for release by the end of the year, but preparing by upgrading to 7.96 will expedite the upgrade when it becomes available.

See Upgrade for PCI Compliance for full information, including information on operating systems and browsers.

For more information on preparing to the upgrade to 7.96, see How to prepare for the installation of Microsoft .NET Framework 4.6 which is required for Raiser's Edge 7.96, and review the following article before upgrading from 7.93: What do I need to do to prepare for the update to The Raiser's Edge 7.95 or higher?

More information can also be found in the 7.96 release webinar on the Raiser's Edge New Release Community.
Blackbaud is requiring customers to upgrade to versions of their products that support TLS v.1.1 or higher by March 15, 2018. On that date, Blackbaud will begin disabling the TLS v.1.0 encryption protocol in our solutions, so Blackbaud can complete development and testing prior to the PCI Council’s June 30, 2018 deadline. After March 15, 2018, customers still using TLS v.1.0 will not be able to access some of their Blackbaud solutions.