What operating systems and browsers support TLS 1.1 or higher?

With the upcoming deprecation of the TLS 1.0 protocol, it will be necessary to use an operating system and/or browser that have support for the TLS 1.1 (or higher) encryption protocol.  This will be necessary for clients and donors to connect to Blackbaud hosted products or services and any hosted products or services after the deprecation of TLS 1.0.  Blackbaud will begin deprecating this protocol beginning March 15th, 2018.

Most donors and Blackbaud clients using modern browsers and operating systems will not be impacted.  Only very old browsers and operating systems will be unable to make connections using the newer TLS protocol.  Beginning March 15th, 2018 it will be necessary to use an operating system and browser capable of connections using TLS 1.1 or higher.

See the list below for minimum required versions. For additional information, please visit https://www.blackbaud.com/tls

Compatible Operating Systems:
Windows 7
Windows 8
Windows 8.1
Windows 10
Windows Server 2008 R2
Windows Server 2012

Compatible Browsers:
Chrome v22 or higher
Firefox v27 or higher
Internet Explorer 8-10 (if TLS 1.1 is enabled)
Internet Explorer 11 and higher (TLS 1.1 is enabled by default)
Safari v7 or higher
Edge

Compatible Mobile Browsers:
Chrome on Android Jelly Bean 4.1-4.3.1 and Android KitKat 4.4-4.4.4 (if TLS 1.1 is enabled)
Chrome on Android Lollipop 5.0-5.0.2 and higher (TLS 1.1 is enabled by default)
Safari v5 and higher
Internet Explorer Mobile on Windows Phone 8 (if TLS 1.1 is enabled)
Internet Explorer Mobile on Windows Phone 8.1 and higher (TLS 1.1 is enabled by default)
Edge all versions
Opera 12.18 and later.

Environment

 Chrome;Firefox;Internet Explorer;Opera;Safari

Was this article helpful?