Required constituent attributes missing when adding a relationship record as a constituent

Saving relationship and then converting to Constituent does not prompt for required attributes
Required fields for constituent do not apply to relationship (non-constituent) records, this includes the act of promoting them to Constituent.

We recommend adding any program suggestions to our Ideas Community page. Our developers check here first when building program enhancements to see what our users are most interested in seeing implemented.

Steps to Duplicate

  1. In Config > Attributes - Create a new Constituent attribute and mark it as required
  2. Add a new constituent but do not specify any attributes - Notice prompt that a required attribute is missing
  3. Supply attribute and save constituent record
  4. On Relationships tab, add a new individual relationship
  5. Supply at least the last name and then save/close relationship
  6. On Relationship tab, double-click to open the new relationship
  7. From the top menu click Relationship > Add individual as Constituent
  8. Supply any constituency code/date and click OK
  9. Notice there is no prompt for required attributes and constituent record saves without the required attributes
Users are prompted for the required attributes if the above is performed without an initial save to the relationship record.  For instance, a new relationship is created and added as a constituent before the relationship record is saved, a prompt that attributes are missing will appear.  However, this does not apply if working with old/existing relationship records.

Environment

 Raiser's Edge
 7.96

Was this article helpful?