Error: This RE constituent is already linked to NetCommunity user: XXX when processing Email Signup transaction

When processing an Email Signup transaction through the NetCommunity plugin within The Raiser's Edge, you may receive the error "This RE constituent is already linked to NetCommunity user: XXX" when the constituent record is linked to a NetCommunity user.
Download and install the latest patch, which contains all fixes from previous patches. If you are running an older version, download and install the latest version and then the patch. If you are hosted by Blackbaud and have not yet been upgraded to the latest version, please follow the steps below for an alternative solution:

Workaround:
 
  1. Choose to create a new constituent record and process this transaction to the new record
  2. Merge the new constituent record with the updated email information into the existing constituent record

Environment

 Blackbaud NetCommunity
 7.1
 7.1
 7.1 Service Pack 3 Hotfix 1 (7.1.199.0)

Was this article helpful?