Error Invalid Datatype Specified MicroEdge FIMS Reports Viewer Control when Running Edit Reports After Upgrading to 14.60

After upgrading to 14.60 the error, "Invalid Datatype Specified: MicroEdge.FIMS.Reports Viewer Control. Specify a datatype such as 'character' or the name of a class. (5638) **n:\found\fims\GUI\Reports\ReportViewer.cls. Could not understand line 33. (196).

This has been noted on three edit reports: Gift Edit report, Grant Edit report and AP edit report.
This issue usually occurs on the workstation and not the server. You will many times see a message window flash on the workstation saying that .Net assemblies failed to update.

This issue is due to the .Net assemblies having been changed during the upgrade and they were not updated on the workstation where the issue is ocurring. After the .Net assemblies are updated on the workstation, the error will disappear.

Update .Net assemblies on the workstation where the issue occurs. 

If the solution above does not work to resolve the errors in edit reports, log into FIMS on the server and run the edit report in question there. If the issue also occurs on the server then that indicates that the upgrade needs to be ran again due to errors\issues that most likely occurred during the upgrade process that were not addressed at that time. The command window of the upgrade should contain no errors, and there should be no errors in the Compile window when that step of the upgrade occurs.

See the following documentation on the upgrade process:
https://www.blackbaud.com/files/support/guides/microedge/fims/fims_upgradeguide.pdf

 

Environment

 FIMS

Was this article helpful?