Blackbaud MobilePay works with Android 4.4 and higher and the two most recent iOS versions. While not all mobile phones and tablets are compatible, nearly all Apple devices are compatible and most Android devices, including but not limited to: 
  • LG G Pad F 8.0
  • ASUS Memo Pad 7
  • Ellipsis 7 QMV7B (Verizon)
  • Motorola DROID Turbo 2 XT1585 (Verizon)
  • Nexus 7 (Second Generation)
  • Samsung Galaxy Note 8
  • Samsung Galaxy S7 (Verizon)
  • Samsung Galaxy S7 Edge (AT&T)
  • Samsung Galaxy S8
  • Samsung Galaxy Tab E

You can find most Android or Apple operating system information by following these steps: 

Android, go to Settings>About Phone>Software Information
iOS, go to Settings>General>About>Version

For additional information on compatibility as well as common troubleshooting steps, please refer to the FAQ for MobilePay