Error: Content Can Not Be Displayed in an iFrame

When viewing a Blackbaud NetCommunity or Blackbaud Internet Solutions page through an iFrame, users receive the error message: Content can not be displayed in an iFrame.

As part of our normal product improvement processes, we review our security measures, protocols, and infrastructure on an ongoing basis. Blackbaud NetCommunity is regularly updated to include security improvements which address vulnerabilities that could potentially compromise the integrity of our product. As part of these security improvements we will remove the ability for you to display Blackbaud NetCommunity pages or forms in iFrames. 

The removal of iFrames prevents a hacker from attempting to add malicious code into the various forms and capturing personal or payment information from your users. Blackbaud has historically not recommended the use of iFrames due to these security issues.  Our decision to remove the use of iFrames has been made in order to ensure the integrity of our customers’ websites. This change will go into effect with our next release, which is Blackbaud NetCommunity 7.1 SP2.

If your organization is currently using iFrames, Blackbaud recommends that you take immediate action to remove them. Blackbaud recommends that you create templates in your Blackbaud NetCommunity sites to match your existing websites so that users can seamlessly transition to the NetCommunity page. If you need assistance creating templates that match your existing website design, contact your Account Executive for more information on design services provided by Blackbaud.

Additionally, as of February 26, 2017, the use of Blackbaud Secure Payments (BBSP) pages within an iFrame will no longer be permitted; this will ensure the integration of our customers' websites and data. The removal of iFrame support for the Blackbaud Secure Payments pages prevents a hacker from attempting to add malicious code into the various forms and capturing personal or payment information from your users. Blackbaud has historically not recommended the use of iFrames with BBSP pages due to these security issues.

Blackbaud apologizes for any inconvenience that this may cause.  We are committed to ensuring our products meet the highest level of quality, reliability, and security. 

Environment

 Blackbaud NetCommunity
 7.1
 Service Pack 2

Was this article helpful?